颠覆:Tortoise + AnkhSVN

Asked
Viewd5665

1

Open Ankh似乎正在使用Subversion 1.6.2,而Tortoise使用的是Subversion 1.6.0。

使用Tortoise创建存储库后,我无法再看到它了。

下载Subversion并执行后 svn admin -create --pre-1.6-compatible z:\ ...... \ etc .. 现在ankh可以看到它。这是我第一次使用版本控制,也许我不需要乌龟,但是Windows资源管理器的集成听起来不错。

我使用的是file:///,而不是svnserve或Apache。

我将能够在ankh一侧使用乌龟,还是会继续出现问题或可能损坏存储库?

  • 对不起,这应该读为AnkhSvn似乎正在使用Subversion 1.6.0,而乌龟似乎正在使用Subversion 1.6.2。将尝试每天构建ankhSVN

    MaslowMay 19, 2009 14:29

5 个答案

3

我遇到了类似的问题,但是通过安装最新的AnkhSVN(每天2.1版)来解决了这些问题。

0

我也遇到了Ankh的问题,但是在安装Subversion 1.6.2之后它就可以了! 所以可能您需要将您的Subversion更新为1.6.2

  • 我实际上不需要安装Subversion来解决此问题。

    MaslowMay 20, 2009 02:30
7

只要这两个工具都在Subversion的主/次版本(即1.6.any)上,则它们应该能够一起工作。

您是否在谈论AnkhSVN?如果是这样,您可能需要获取每日构建,因为他们的页面提到使用最新的Subversion 1.6每日支持。 http://ankhsvn.open.collab.net/

如果您更新一个客户端而不更新另一个客户端,并且版本差异较小(即1.6与1.5),则较新的客户端将更新工作副本,而您将无法在较旧的客户端中使用它

  • 是的AnkhSvn,尝试每天进行一次构建以查看是否有帮助。

    MaslowMay 19, 2009 14:28
1

TortoiseSVN的最新版本是针对SVN 1.6.2构建的,请在此处获取。那可能会解决您的问题。

原始海报纠正了他的帖子,以上行不再适用。

您应该可以并排使用,而不会出现任何问题。我有一段时间了,没有遇到任何问题

  • 您说您已经使用了一段时间,是否更改了版本控制程序,或者使用其中一个足以删除另一个程序?

    MaslowMay 19, 2009 14:27
  • 我放弃使用Ankh的原因有两个:1)它是较早的版本,确实具有新版本的SCC支持,2)它与我正在使用的ASP.NET网站项目不能很好地配合继续,3)我只是更喜欢TortoiseSVN,最后4)我离开了最后一位雇主,而我目前的雇主拥有更加严格的软件指南,因此我必须获得Ankh的批准。

    Dan McClainMay 19, 2009 16:35